wcs/debian/rules

27 lines
702 B
Makefile
Executable File

#!/usr/bin/make -f
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
%:
dh $@ --with python2
override_dh_clean:
dh_clean
rm -rf po/*.mo
override_dh_install:
dh_install
mv $(CURDIR)/debian/wcs/usr/bin/wcsctl.py \
$(CURDIR)/debian/wcs/usr/sbin/wcsctl
rmdir $(CURDIR)/debian/wcs/usr/bin/
cd po && make install prefix=$(CURDIR)/debian/wcs/
cp debian/vhost-apache-wcs $(CURDIR)/debian/wcs/etc/apache2/sites-available
chown www-data.www-data $(CURDIR)/debian/wcs/var/lib/wcs/
install -d $(CURDIR)/debian/wcs/etc/wcs
install -m 644 wcs.cfg-sample $(CURDIR)/debian/wcs/etc/wcs/wcs.cfg
override_dh_fixperms:
dh_fixperms -X /var/lib/wcs