This repository has been archived on 2023-02-21. You can view files and clone it, but cannot push or open issues or pull requests.
ifef-registration/debian/rules

60 lines
1.2 KiB
Makefile
Executable File

#!/usr/bin/make -f
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
PYTHON=/usr/bin/python
build: build-stamp
build-stamp:
dh_testdir
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
cd po && rm -f *.mo
python setup.py clean
rm -rf build
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(PYTHON) setup.py install --prefix=$(CURDIR)/debian/authentic-ifef/usr --no-compile
cd po && make install prefix=$(CURDIR)/debian/authentic-ifef/
cp ldap/ifef.schema $(CURDIR)/debian/authentic-ifef/etc/ldap/schema/
cp debian/apache2-ifef.conf $(CURDIR)/debian/authentic-ifef/usr/share/authentic/
cp debian/vhost-apache-authentic-ifef $(CURDIR)/debian/authentic-ifef/etc/apache2/sites-available/authentic-ifef
# Build architecture-independent files here.
binary-indep: build install
dh_testdir
dh_testroot
dh_installdocs
dh_installchangelogs
dh_installinit
dh_link
dh_strip
dh_compress
dh_fixperms
dh_pysupport
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch: build install
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install