This repository has been archived on 2023-02-21. You can view files and clone it, but cannot push or open issues or pull requests.
ifef-registration/debian/authentic-ifef.postinst

26 lines
475 B
Bash

#!/bin/sh -e
case "$1" in
triggered)
if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
invoke-rc.d authentic-ifef restart || exit $?
else
/etc/init.d/authentic-ifef restart || exit $?
fi
;;
*)
#DEBHELPER#
# Rerun slapd since schema could have been modified
if [ -f /etc/init.d/slapd ]; then
if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
invoke-rc.d slapd restart || exit $?
else
/etc/init.d/slapd restart || exit $?
fi
fi
;;
esac
exit 0