debian-python-cssselect2/patches/0001-Remove-pytest-flake8-a...

36 lines
987 B
Diff

From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Tue, 13 Nov 2018 16:14:15 +0100
Subject: Remove pytest-flake8 and pytest-isort from test runs.
---
setup.cfg | 1 -
setup.py | 4 ++--
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/setup.cfg b/setup.cfg
index 99b7654..a8e09d8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,7 +5,6 @@ test = pytest
universal = 1
[tool:pytest]
-addopts = --cov=cssselect2 --flake8 --isort cssselect2
norecursedirs = dist .cache .git build *.egg-info .eggs venv
[egg_info]
diff --git a/setup.py b/setup.py
index bdf7ac4..a11d408 100755
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ setup(
setup_requires=pytest_runner,
test_suite='cssselect2.tests',
tests_require=[
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort'],
+ 'pytest-runner'],
extras_require={'test': [
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort']},
+ 'pytest-runner']},
)