debian-django-select2/debian/patches/01_use_xstatic_select2.diff

45 lines
1.4 KiB
Diff

Index: django-select2/django_select2/conf.py
===================================================================
--- django-select2.orig/django_select2/conf.py
+++ django-select2/django_select2/conf.py
@@ -5,6 +5,8 @@ from __future__ import absolute_import,
from appconf import AppConf
from django.conf import settings # NOQA
+from gadjo.templatetags.gadjo import xstatic
+
__all__ = ('settings', 'Select2Conf')
@@ -48,7 +50,7 @@ class Select2Conf(AppConf):
It has set `select2_` as a default value, which you can change if needed.
"""
- JS = '//cdnjs.cloudflare.com/ajax/libs/select2/4.0.3/js/select2.min.js'
+ JS = xstatic('select2', 'select2.min.js')
"""
The URI for the Select2 JS file. By default this points to the Cloudflare CDN.
@@ -61,7 +63,7 @@ class Select2Conf(AppConf):
develop without an Internet connection.
"""
- CSS = '//cdnjs.cloudflare.com/ajax/libs/select2/4.0.3/css/select2.min.css'
+ CSS = xstatic('select2', 'select2.min.css')
"""
The URI for the Select2 CSS file. By default this points to the Cloudflare CDN.
Index: django-select2/setup.py
===================================================================
--- django-select2.orig/setup.py
+++ django-select2/setup.py
@@ -49,6 +49,8 @@ setup(
],
install_requires=[
'django-appconf>=0.6.0',
+ 'XStatic-Select2',
+ 'gadjo',
],
zip_safe=False,
)