python-tinycss2 (0.6.1-1) unstable; urgency=low

* Initial release (Closes: #903817).

[dgit import unpatched python-tinycss2 0.6.1-1]
This commit is contained in:
Michael Fladischer 2018-07-15 12:08:24 +02:00
commit 10cfd45c85
16 changed files with 270 additions and 0 deletions

5
debian/changelog vendored Normal file
View File

@ -0,0 +1,5 @@
python-tinycss2 (0.6.1-1) unstable; urgency=low
* Initial release (Closes: #903817).
-- Michael Fladischer <fladi@debian.org> Sun, 15 Jul 2018 12:08:24 +0200

6
debian/clean vendored Normal file
View File

@ -0,0 +1,6 @@
.coverage
.eggs/README.txt
.pytest_cache/v/cache/nodeids
tinycss2.egg-info/PKG-INFO
tinycss2.egg-info/requires.txt

1
debian/compat vendored Normal file
View File

@ -0,0 +1 @@
11

84
debian/control vendored Normal file
View File

@ -0,0 +1,84 @@
Source: python-tinycss2
Section: python
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders:
Michael Fladischer <fladi@debian.org>,
Build-Depends:
debhelper (>= 11),
dh-python,
python3-all,
python3-pytest-cov,
python3-pytest-runner,
python3-setuptools,
python3-sphinx,
python3-sphinx-rtd-theme,
python3-webencodings,
Standards-Version: 4.1.5
Homepage: https://github.com/Kozea/tinycss2/
Vcs-Git: https://salsa.debian.org/python-team/modules/python-tinycss2.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/python-tinycss2
Testsuite: autopkgtest-pkg-python
Package: python-tinycss2-doc
Section: doc
Architecture: all
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Description: Low-level CSS parser (Documentation)
tinycss2 is a rewrite of tinycss with a simpler API, based on the more recent
CSS Syntax Level 3 specification.
.
tinycss2 is low-level in that it doesnt parse all of CSS: it doesn't know
about the syntax of any specific properties or at-rules. Instead, it provides a
set of functions that can be composed to support exactly the parts of CSS
you're interested in, including new or non-standard rules or properties,
without modifying tinycss or having a complex hook/plugin system.
.
In many cases, parts of the parsed values (such as the content of a AtRule) is
given as component values that can be parsed further with other functions.
.
This package contains the documentation.
Package: python3-tinycss2
Architecture: all
Depends:
${misc:Depends},
${python3:Depends},
python-tinycss2-common,
Suggests:
python-tinycss2-doc,
Description: Low-level CSS parser (Python3 version)
tinycss2 is a rewrite of tinycss with a simpler API, based on the more recent
CSS Syntax Level 3 specification.
.
tinycss2 is low-level in that it doesnt parse all of CSS: it doesn't know
about the syntax of any specific properties or at-rules. Instead, it provides a
set of functions that can be composed to support exactly the parts of CSS
you're interested in, including new or non-standard rules or properties,
without modifying tinycss or having a complex hook/plugin system.
.
In many cases, parts of the parsed values (such as the content of a AtRule) is
given as component values that can be parsed further with other functions.
.
This package contains the Python 3 version of the library.
Package: python-tinycss2-common
Architecture: all
Depends:
${misc:Depends},
Description: Low-level CSS parser (test data)
tinycss2 is a rewrite of tinycss with a simpler API, based on the more recent
CSS Syntax Level 3 specification.
.
tinycss2 is low-level in that it doesnt parse all of CSS: it doesn't know
about the syntax of any specific properties or at-rules. Instead, it provides a
set of functions that can be composed to support exactly the parts of CSS
you're interested in, including new or non-standard rules or properties,
without modifying tinycss or having a complex hook/plugin system.
.
In many cases, parts of the parsed values (such as the content of a AtRule) is
given as component values that can be parsed further with other functions.
.
This package contains the test data of the library.

47
debian/copyright vendored Normal file
View File

@ -0,0 +1,47 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: python-tinycss2
Upstream-Contact: Simon Sapin <simon.sapin@exyr.org>
Source: https://github.com/Kozea/tinycss2/
Files: *
Copyright: 2013-2018, Simon Sapin and contributors (see AUTHORS)
License: BSD-3-clause
Files: tinycss2/css-parsing-tests/*
Copyright: 2013, Simon Sapin
License: CC0
Files: debian/*
Copyright: 2018, Michael Fladischer <fladi@debian.org>
License: BSD-3-clause
License: BSD-3-clause
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
.
* Redistributions of source code must retain the above copyright notice, this
list of conditions and the following disclaimer.
.
* Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
.
* Neither the name of the copyright holder nor the names of its
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.
.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
License: CC0
To the extent possible under law, the author(s) have dedicated all copyright
and related and neighboring rights to this work to the public domain worldwide.
This work is distributed without any warranty.

View File

@ -0,0 +1,37 @@
From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Tue, 10 Jul 2018 10:05:00 +0200
Subject: Do not use pytest-isort and pytest-flake8 in tests,
not packaged yet.
---
setup.cfg | 2 +-
setup.py | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/setup.cfg b/setup.cfg
index ae602ff..a6452e5 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,7 +5,7 @@ test = pytest
universal = 1
[tool:pytest]
-addopts = --cov=tinycss2 --flake8 --isort tinycss2/test.py
+addopts = --cov=tinycss2 tinycss2/test.py
norecursedirs = dist .cache .git build *.egg-info .eggs venv
[egg_info]
diff --git a/setup.py b/setup.py
index ee27778..628b571 100755
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,7 @@ setup(
setup_requires=pytest_runner,
test_suite='tinycss2.test',
tests_require=[
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort'],
+ 'pytest-runner', 'pytest-cov'],
extras_require={'test': [
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort']},
+ 'pytest-runner', 'pytest-cov']},
)

View File

@ -0,0 +1,21 @@
From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Tue, 10 Jul 2018 10:27:19 +0200
Subject: Decode test data using UTF-8.
---
tinycss2/test.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tinycss2/test.py b/tinycss2/test.py
index 3847619..cac42b9 100644
--- a/tinycss2/test.py
+++ b/tinycss2/test.py
@@ -79,7 +79,7 @@ def to_json():
def load_json(filename):
json_data = json.load(open(os.path.join(
- os.path.dirname(__file__), 'css-parsing-tests', filename)))
+ os.path.dirname(__file__), 'css-parsing-tests', filename), encoding='utf-8'))
return list(zip(json_data[::2], json_data[1::2]))

View File

@ -0,0 +1,22 @@
From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Tue, 10 Jul 2018 10:44:35 +0200
Subject: Convert travis-ci badge to text link to avoid privacy breach.
---
README.rst | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/README.rst b/README.rst
index d70661c..ad1fe13 100644
--- a/README.rst
+++ b/README.rst
@@ -12,8 +12,4 @@ based on the more recent `CSS Syntax Level 3`_ specification.
* Latest documentation: http://tinycss2.readthedocs.io/
* Source code and issue tracker: https://github.com/Kozea/tinycss2
* PyPI releases: https://pypi.python.org/pypi/tinycss2/
-* Continuous integration: |travis|
-
-.. |travis| image:: https://travis-ci.org/Kozea/tinycss2.svg?branch=master
- :target: https://travis-ci.org/Kozea/tinycss2
- :alt: https://travis-ci.org/Kozea/tinycss2
+* Continuous integration: https://travis-ci.org/Kozea/tinycss2.svg?branch=master

3
debian/patches/series vendored Normal file
View File

@ -0,0 +1,3 @@
0001-Do-not-use-pytest-isort-and-pytest-flake8-in-tests-n.patch
0002-Decode-test-data-using-UTF-8.patch
0003-Convert-travis-ci-badge-to-text-link-to-avoid-privac.patch

1
debian/python-tinycss2-common.docs vendored Normal file
View File

@ -0,0 +1 @@
tinycss2/css-parsing-tests/README.rst

8
debian/python-tinycss2-doc.doc-base vendored Normal file
View File

@ -0,0 +1,8 @@
Document: python-tinycss2-doc
Title: tinycss2 Documentation
Author: Simon Sapin <simon.sapin@exyr.org>
Section: Programming/Python
Format: HTML
Index: /usr/share/doc/python-tinycss2-doc/html/index.html
Files: /usr/share/doc/python-tinycss2-doc/html/*.html

1
debian/python3-tinycss2.docs vendored Normal file
View File

@ -0,0 +1 @@
README.rst

1
debian/python3-tinycss2.links vendored Normal file
View File

@ -0,0 +1 @@
usr/share/python-tinycss2-common/css-parsing-tests usr/lib/python3/dist-packages/tinycss2/css-parsing-tests

29
debian/rules vendored Executable file
View File

@ -0,0 +1,29 @@
#!/usr/bin/make -f
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=tinycss2
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install
rm -rf debian/python3-tinycss2/usr/lib/python*/*-packages/tinycss2/css-parsing-tests
mkdir -p debian/python-tinycss2-common/usr/share/python-tinycss2-common
cp -r tinycss2/css-parsing-tests debian/python-tinycss2-common/usr/share/python-tinycss2-common/css-parsing-tests
rm -f debian/python-tinycss2-common/usr/share/python-tinycss2-common/css-parsing-tests/LICENSE
rm -f debian/python-tinycss2-common/usr/share/python-tinycss2-common/css-parsing-tests/README.rst
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. sphinx-build -b html -N docs/ $(CURDIR)/debian/python-tinycss2-doc/usr/share/doc/python-tinycss2-doc/html
dh_sphinxdoc
endif
override_dh_clean:
rm -rf docs/.build
dh_clean

1
debian/source/format vendored Normal file
View File

@ -0,0 +1 @@
3.0 (quilt)

3
debian/watch vendored Normal file
View File

@ -0,0 +1,3 @@
version=3
opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
https://pypi.debian.net/tinycss2/tinycss2-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))