Import python-cssselect2_0.2.1-1.debian.tar.xz

[dgit import tarball python-cssselect2 0.2.1-1 python-cssselect2_0.2.1-1.debian.tar.xz]
This commit is contained in:
Michael Fladischer 2018-11-13 19:13:59 +01:00
commit 39344105c9
15 changed files with 203 additions and 0 deletions

5
changelog Normal file
View File

@ -0,0 +1,5 @@
python-cssselect2 (0.2.1-1) unstable; urgency=low
* Initial release (Closes: #913669).
-- Michael Fladischer <fladi@debian.org> Tue, 13 Nov 2018 19:13:59 +0100

3
clean Normal file
View File

@ -0,0 +1,3 @@
.pytest_cache/v/cache/nodeids
cssselect2.egg-info/PKG-INFO
cssselect2.egg-info/requires.txt

1
compat Normal file
View File

@ -0,0 +1 @@
11

56
control Normal file
View File

@ -0,0 +1,56 @@
Source: python-cssselect2
Section: python
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders:
Michael Fladischer <fladi@debian.org>,
Build-Depends:
debhelper (>= 11),
dh-python,
python3-all,
python3-pytest,
python3-pytest-runner,
python3-setuptools,
python3-sphinx,
python3-sphinx-rtd-theme,
python3-tinycss2,
Standards-Version: 4.2.1
Homepage: https://github.com/Kozea/cssselect2/
Vcs-Browser: https://salsa.debian.org/python-team/modules/python-cssselect2
Vcs-Git: https://salsa.debian.org/python-team/modules/python-cssselect2.git
Testsuite: autopkgtest-pkg-python
Package: python-cssselect2-doc
Section: doc
Architecture: all
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Description: implementation of CSS3 Selectors (Documentation)
cssselect2 is a straightforward implementation of CSS3 Selectors for markup
documents (HTML, XML, etc.) that can be read by ElementTree-like parsers
(including cElementTree, lxml, html5lib, etc.)
.
Unlike cssselect, it does not translate selectors to XPath and therefore does
not have all the correctness corner cases that are hard or impossible to fix in
cssselect.
.
This package contains the documentation.
Package: python3-cssselect2
Architecture: all
Depends:
${misc:Depends},
${python3:Depends},
Suggests:
python-cssselect2-doc,
Description: implementation of CSS3 Selectors (Python3 version)
cssselect2 is a straightforward implementation of CSS3 Selectors for markup
documents (HTML, XML, etc.) that can be read by ElementTree-like parsers
(including cElementTree, lxml, html5lib, etc.)
.
Unlike cssselect, it does not translate selectors to XPath and therefore does
not have all the correctness corner cases that are hard or impossible to fix in
cssselect.
.
This package contains the Python 3 version of the library.

43
copyright Normal file
View File

@ -0,0 +1,43 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: python-cssselect2
Upstream-Contact: Simon Sapin <simon.sapin@exyr.org>
Source: https://github.com/Kozea/cssselect2/
Files: *
Copyright:
2012-2018, Simon Sapin and contributors (see AUTHORS)
2017, Guillaume Ayoub
License: BSD-3-clause
Files: debian/*
Copyright: 2018, Michael Fladischer <fladi@debian.org>
License: BSD-3-clause
License: BSD-3-clause
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:
.
* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
.
* Redistributions in binary form must reproduce the above
copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided
with the distribution.
.
* The names of the contributors may not be used to endorse or
promote products derived from this software without specific
prior written permission.
.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

View File

@ -0,0 +1,35 @@
From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Tue, 13 Nov 2018 16:14:15 +0100
Subject: Remove pytest-flake8 and pytest-isort from test runs.
---
setup.cfg | 1 -
setup.py | 4 ++--
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/setup.cfg b/setup.cfg
index 99b7654..a8e09d8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,7 +5,6 @@ test = pytest
universal = 1
[tool:pytest]
-addopts = --cov=cssselect2 --flake8 --isort cssselect2
norecursedirs = dist .cache .git build *.egg-info .eggs venv
[egg_info]
diff --git a/setup.py b/setup.py
index bdf7ac4..a11d408 100755
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ setup(
setup_requires=pytest_runner,
test_suite='cssselect2.tests',
tests_require=[
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort'],
+ 'pytest-runner'],
extras_require={'test': [
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort']},
+ 'pytest-runner']},
)

View File

@ -0,0 +1,21 @@
From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Tue, 13 Nov 2018 16:14:37 +0100
Subject: Use proper encoding for reading test data.
---
cssselect2/tests/test_cssselect2.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cssselect2/tests/test_cssselect2.py b/cssselect2/tests/test_cssselect2.py
index 2e9dbc4..900ad23 100644
--- a/cssselect2/tests/test_cssselect2.py
+++ b/cssselect2/tests/test_cssselect2.py
@@ -24,7 +24,7 @@ def resource(filename):
def load_json(filename):
- return json.load(open(resource(filename)))
+ return json.load(open(resource(filename), encoding='utf-8'))
def get_test_document():

2
patches/series Normal file
View File

@ -0,0 +1,2 @@
0001-Remove-pytest-flake8-and-pytest-isort-from-test-runs.patch
0002-Use-proper-encoding-for-reading-test-data.patch

View File

@ -0,0 +1,8 @@
Document: python-cssselect2-doc
Title: cssselect2 Documentation
Author: Simon Sapin <simon.sapin@exyr.org>
Section: Programming/Python
Format: HTML
Index: /usr/share/doc/python-cssselect2-doc/html/index.html
Files: /usr/share/doc/python-cssselect2-doc/html/*.html

1
python-cssselect2.docs Normal file
View File

@ -0,0 +1 @@
README.rst

1
python3-cssselect2.docs Normal file
View File

@ -0,0 +1 @@
README.rst

View File

@ -0,0 +1,2 @@
# Used for unittests only and not loaded when run.
python3-cssselect2: privacy-breach-generic usr/lib/python3/dist-packages/cssselect2/tests/content.xhtml [<link id="pseudo-link-link2" href="http://example.org/"/>] (http://example.org/)

21
rules Executable file
View File

@ -0,0 +1,21 @@
#!/usr/bin/make -f
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=cssselect2
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install
rm -f debian/python*-cssselect2/usr/lib/python*/dist-packages/cssselect2/tests/LICENSE
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. python3 -m sphinx -b html -N docs/ $(CURDIR)/debian/python-cssselect2-doc/usr/share/doc/python-cssselect2-doc/html
dh_sphinxdoc
endif

1
source/format Normal file
View File

@ -0,0 +1 @@
3.0 (quilt)

3
watch Normal file
View File

@ -0,0 +1,3 @@
version=3
opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
https://pypi.debian.net/cssselect2/cssselect2-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))