Removing 01-fix-codec-error.patch, patch must be applied on tarball.

This commit is contained in:
Mathias Behrle 2015-05-21 17:34:40 +02:00
parent 91612723ba
commit 4db0765306
2 changed files with 0 additions and 41 deletions

View File

@ -1,40 +0,0 @@
Description: Fixing UnicodeDecodeError in setup.py.
Fixes:
I: pybuild base:170: python3.4 setup.py clean
Traceback (most recent call last):
File "setup.py", line 15, in
history = open('HISTORY.rst').read().replace('.. :changelog:', '')
File "/usr/lib/python3.4/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
i : 'ascii' codec can't decode byte 0xe2 in position 561: ordinal not in range(128)
Author: Mathias Behrle <mathiasb@m9s.biz>
Origin: https://github.com/mbehrle/cached-property/commit/e75addd999cdd702675fdb27c9eaefe51fe68e06
Bug: https://github.com/pydanny/cached-property/issues/22
Forwarded: https://github.com/pydanny/cached-property/pull/23
--- cached-property.orig/setup.py 2015-05-12 15:31:55.692859294 +0200
+++ cached-property/setup.py 2015-05-12 15:31:55.688859329 +0200
@@ -3,6 +3,7 @@
import os
import sys
+import codecs
try:
from setuptools import setup
@@ -11,8 +12,13 @@
__version__ = '1.2.0'
-readme = open('README.rst').read()
-history = open('HISTORY.rst').read().replace('.. :changelog:', '')
+
+def read(fname):
+ return codecs.open(
+ os.path.join(os.path.dirname(__file__), fname), 'r', 'utf-8').read()
+
+readme = read('README.rst')
+history = read('HISTORY.rst').replace('.. :changelog:', '')
if sys.argv[-1] == 'publish':
os.system('python setup.py sdist bdist_wheel upload')

View File

@ -1 +0,0 @@
01-fix-codec-error.patch